FZ 07 Owners Club banner

1 - 7 of 7 Posts

·
Registered
Joined
·
27 Posts
Discussion Starter #1
Replacing the not-so-attractive front indicators. Purchased a set of "Traf-X", very cool looking but am unable to install. It would involve cutting and splicing which is not my thing. Just want a pair that looks awesome, bright, and plug in and go. Suggestions fellow FZ-07 owners?
 

·
Registered
Joined
·
6 Posts
Most aftermarket options (I can't say I am completely familiar with the Traf-X option) come with bullet connectors. Do a quick search on "Yamaha Indicator Wiring Adapters" and you will find a number of options that allow installation of the aftermarket without cutting. It is a simple bullet-style pigtail connector to the Yamaha-Style connector; Plug in and go!

Example: DMP Turn Signal - Harness | MotoSport
 

·
Registered
Joined
·
27 Posts
Discussion Starter #3
Two attempts to install new (better looking) front signal indicators. Fail... Now the original blinkers do not work. They light up as running lights but will not flash/blink as before. Any suggestions appreciated.
 

·
Registered
Joined
·
27 Posts
Discussion Starter #4
Most aftermarket options (I can't say I am completely familiar with the Traf-X option) come with bullet connectors. Do a quick search on "Yamaha Indicator Wiring Adapters" and you will find a number of options that allow installation of the aftermarket without cutting. It is a simple bullet-style pigtail connector to the Yamaha-Style connector; Plug in and go!

Example: DMP Turn Signal - Harness | MotoSport
Bought the wiring adapters and still did not work ;(. Replaced the original blinkers and now they do not work :( The running light is on, but the blinkers will not flash. Any ideas?
 

·
Registered
Joined
·
22 Posts
Should be 3 wires. Sounds like you connected the running lights and not the turn signal. Do you have an adaptor for a 2 to 3 connection?
 

·
Registered
Joined
·
27 Posts
Discussion Starter #6
Should be 3 wires. Sounds like you connected the running lights and not the turn signal. Do you have an adaptor for a 2 to 3 connection?
Yes, we just can't get anything to work. Broke down and took it to the Yamaha Dealer service dept. $$$$$$ cha-ching.
 
1 - 7 of 7 Posts
Top