FZ 07 Owners Club banner

1 - 3 of 3 Posts

·
Registered
Joined
·
1 Posts
Discussion Starter #1
So here is the story, I bought a fz 07 from the auction salvage title. The bike as mentioned by the auction runs and drives fine with no issues. So I believed them and bought it but when I got it at my house it started fine. But when I put the bike in gear and slowly let the clutch out and gave the bike some throttle the bike was not moving at all. I could easily switch gears with no problem. I then turned off the bike and put it in 2nd gear and tried to push it, and when I did that the bike moved forward when pushed with not much resistance. Also the bikes battery is dead, and it has been sitting on its side stand for a good while. So after that while the bike is off I also noticed that I could switch gears without pushing the clutch in. Now i am left with no hope at all, tried to take it to the auction back but they gave me some bs. please help I really was looking forward to ride this bike.
Thanks
 

·
Registered
Joined
·
4 Posts
Welcome GarrettWills!
I would suggest as mentioned before, check the clutch adjustment, then see if the clutch is engaging at all. From what you are saying, the clutch is not engaging since you can push it easily in the 2nd gear.
I've got mine at auction as well, and mine had a hole in the clutch cover (from skidding) but I replaced it and had a little hard time then figuring how to connect the pin from the basket clutch with the rod in the cover. It took me a few tries and some research, but eventually I figured it out and I'm enjoying the bike. Don't give up, you'll do it. Good luck!
 
1 - 3 of 3 Posts
Top