FZ 07 Owners Club banner

1 - 14 of 14 Posts

·
Registered
Joined
·
21 Posts
Discussion Starter #1
I am sure I am not the only one who would like to replace the factory rear fender with a nice clean looking one maybe with some nice LED turn signals... Post them up here as they come out.

I personally would love to see something like this Hotbodies undertail/fender eliminator kit for the FZ-07

my R6 with the undertail/fender eliminator kit




 

·
Registered
Joined
·
21 Posts
Discussion Starter #3
That would be nice but we don't need to change the tail lights is already led
That doesn't replace the tail light. It just integrates turn signals into the tail of the bike and then gives a very low profile mount for your plate. Tucks everything up nice and neat.
 

·
Registered
Joined
·
27 Posts
Hello, I've installed today the Yamaha fender eliminator kit and some LED lights in the front & back from Kellermann, they are called Micro Rhombus PL in the front and Micro Rhombus black in the back.
Motorbike 2.jpg
Motorbike 11.jpg
 

·
Premium Member
Joined
·
18 Posts
Ermax has an Undertail for the FZ-07, in unpainted and 7 additional factory color options. Each kit would look like this:

With the installed product looking a little like this:
 

·
Registered
Joined
·
93 Posts
I put the Yosh kit on today, and I'm really impressed with the quality of the product. Looks great too.
I'm definitely a happy customer.
 

·
Registered
Joined
·
228 Posts
I put the Yosh kit on today, and I'm really impressed with the quality of the product. Looks great too.
I'm definitely a happy customer.
I just set up the fender eliminator - I connected the blinkers and they are working fine. But I cannot get the rear plate light to work not the break light. coming from the bike is a black and blue and from the new light is a red and black. I tried all ways to connect these wires but the rear lights will not work. I tested the plate light and i know it works. Any suggests what I am doing wrong?
 

·
Registered
Joined
·
93 Posts
I just set up the fender eliminator - I connected the blinkers and they are working fine. But I cannot get the rear plate light to work not the break light. coming from the bike is a black and blue and from the new light is a red and black. I tried all ways to connect these wires but the rear lights will not work. I tested the plate light and i know it works. Any suggests what I am doing wrong?
Hmmm... not sure. I remember on my bike it was black to black, so blue to red (don't really remember those colors, but I do remember black to black). Other than that, I would just check for solid connections (I soldered mine). Good Luck.
 

·
Registered
Joined
·
93 Posts
I've got the Akrapovic Ti. I didn't want anything too loud and the Akra Ti with the baffle in is pretty darn quiet (some say too quiet, but I like it).
 

·
Registered
Joined
·
10 Posts
Hello, I've installed today the Yamaha fender eliminator kit and some LED lights in the front & back from Kellermann, they are called Micro Rhombus PL in the front and Micro Rhombus black in the back. View attachment 440 View attachment 441
Snoopy did you remove any parts from the fender eliminator kit? The one on the Yamaha site looks a lot longer. It looks like you removed the middle connection piece.
 
1 - 14 of 14 Posts
Top